re = /(?<=<tag1>[^<>]*)\.(?=[^<>]*<\/tag1>)/m
str = '<tag1>Quomodo restituendus locus Demosth. Olÿnth</tag1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end