using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<queryValue>[0-9,./]+) ?(?P<sourceUnit>[a-zA-Z/\""'^0-9\p{Sc}]+)(?:(?: in | to | as | ?> ?)(?P<targetUnit>[a-zA-Z/\""'^0-9\p{Sc}]+))?$";
string input = @"4/5""
4 m/s
4/3m/s
4/3"" in ms
4/3km/h
4/3km/h in mph
4m in cm
9.0m in cm
9,0m in cm
9,0m>cm
9,0m>cm
9,0 m>cm
9,0 m > cm
9 meters as centimeters
1 m^3
4$>€
4€
4$>¥
# Test queries from https://phabricator.kde.org/D22869
3/8""
3/8 in
3/8"" in cm
3/0""
3""
3€>₱
# Should not match
4 in m/s
4in m/s
4"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}