# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<queryValue>[0-9,./]+) ?(?P<sourceUnit>[a-zA-Z/\"'^0-9\p{Sc}]+)(?:(?: in | to | as | ?> ?)(?P<targetUnit>[a-zA-Z/\"'^0-9\p{Sc}]+))?$"
test_str = ("4/5\"\n"
	"4 m/s\n"
	"4/3m/s\n"
	"4/3\" in ms\n"
	"4/3km/h\n"
	"4/3km/h in mph\n"
	"4m in cm\n"
	"9.0m in cm\n"
	"9,0m in cm\n"
	"9,0m>cm\n"
	"9,0m>cm\n"
	"9,0 m>cm\n"
	"9,0 m > cm\n"
	"9 meters as centimeters\n"
	"1 m^3\n"
	"4$>€\n"
	"4€\n"
	"4$>¥\n\n"
	"# Test queries from https://phabricator.kde.org/D22869\n"
	"3/8\"\n"
	"3/8 in\n"
	"3/8\" in cm\n"
	"3/0\"\n"
	"3\"\n"
	"3€>₱\n\n"
	"# Should not match\n"
	"4 in m/s\n"
	"4in m/s\n"
	"4\">")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.