$re = '/([[:punct:]])\1{2,}/m';
$str = 'asdasdasd - adasdasd asda ------- asda wadsda +-----+ wwww qqqqqq aaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);