re = /([[:punct:]])\1{2,}/m
str = 'asdasdasd - adasdasd asda ------- asda wadsda +-----+ wwww qqqqqq aaaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end