#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\bjack\b.*\bjack\b)(?!.*\bjames\b.*\bjames\b)(?=.*\bjames\b)(?=.*\bjack\b).*$"
Local $sString = "hi jack here is james" & @CRLF & _
"hi james here is jack" & @CRLF & _
"hi james jack here is jack james" & @CRLF & _
"hi jack james here is james jack" & @CRLF & _
"hi jack jack here is jack james" & @CRLF & _
"hi james james here is james jack" & @CRLF & _
"hi jack jack jack here is james" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")