package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^jamec(?:[1-9][0-9]*)?$`)
var str = `jamec
jamec12
jamec1234
jamec01
jamecstuff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}