$re = '/^jamec(?:[1-9][0-9]*)?$/m';
$str = 'jamec
jamec12
jamec1234
jamec01
jamecstuff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);