import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|(?<=[^.?\\/[:alnum:]]))#([\\w\\-]+)";
final String string = " #cli\n"
+ " #cli,\n"
+ " #clocks\n"
+ " #clocks,\n"
+ " #clocksnotes\n"
+ " #clocksnotes,\n"
+ " #clockstxt\n"
+ " #clockstxt,\n\n"
+ "[\"blablabla#querytip\"](https://twitter.com...\n\n"
+ "[\"#querytip\"](https://twitter.com...\n\n"
+ "#I'm";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}