$re = '/(?<=^|(?<=[^.?\/[:alnum:]]))#([\w\-]+)/';
$str = ' #cli
#cli,
#clocks
#clocks,
#clocksnotes
#clocksnotes,
#clockstxt
#clockstxt,
["blablabla#querytip"](https://twitter.com...
["#querytip"](https://twitter.com...
#I\'m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);