// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)SOL:(\d{4})\s+(.*)\s+EXPOZITIE (\w{1,2}) *").unwrap();
let string = "* SOL:1201 тут слова строки текста , EXPOZITIE ST * ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}