import re
regex = re.compile(r"(?:CONTA|C/C)?(?:\sCORRENTE)?\s?(?:PJ)?\s?:?\s?\d+[-./]?\d+", flags=re.MULTILINE)
test_str = ("CONTA CORRENTE: 18465416565\n"
"CONTA: 878976874\n"
"CONTA CORRENTE PJ: 4444546484\n"
"C/C: 88446454564-7897988\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")