import Foundation
let pattern = #"(?:CONTA|C/C)?(?:\sCORRENTE)?\s?(?:PJ)?\s?:?\s?\d+[-./]?\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CONTA CORRENTE: 18465416565
CONTA: 878976874
CONTA CORRENTE PJ: 4444546484
C/C: 88446454564-7897988
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)