import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "instance\\[(\\d+)\\]";
final String string = "hi everyone,\n\n"
+ "i'd like to take a large block of text and find every instance[0] of\n"
+ "a certain word, in this case, instance[1] - and i'd like to replace\n"
+ "every instance[2] number with another number, let's say [3].\n"
+ "string.replace doesn't quite cut it..\n"
+ " \n"
+ "anyone able to help? \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}