// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)instance\[(\d+)\]").unwrap();
let string = "hi everyone,
i'd like to take a large block of text and find every instance[0] of
a certain word, in this case, instance[1] - and i'd like to replace
every instance[2] number with another number, let's say [3].
string.replace doesn't quite cut it..
anyone able to help?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}