#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\b(big|red)\h.*\b\1\b)(?:big\h+|red\h+)*dog$"
Local $sString = "dog" & @CRLF & _
"red dog" & @CRLF & _
"red big dog" & @CRLF & _
"big red dog" & @CRLF & _
"" & @CRLF & _
"red red dog" & @CRLF & _
"red big red dog" & @CRLF & _
"small red dog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")