$re = '/^(?!.*\b(big|red)\h.*\b\1\b)(?:big\h+|red\h+)*dog$/m';
$str = 'dog
red dog
red big dog
big red dog
red red dog
red big red dog
small red dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);