package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(?:-\w+)*-\w{5}`)
var str = `X008-TGa19-ER751QF7
X002-KF13-ER782cPU80`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}