$re = '`^\w+(?:-\w+)*-\w{5}`m';
$str = 'X008-TGa19-ER751QF7
X002-KF13-ER782cPU80';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);