package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{-?([\w\s']{3,})\}`)
var str = `{test}
{Project D'arce}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}