$re = '/\{-?([\w\s\']{3,})\}/m';
$str = '{test}
{Project D\'arce}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);