import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]([-a-z0-9]\\{,61\\}[a-z0-9])?$";
final String string = "a\n"
+ "ab\n"
+ "abc\n"
+ "a-b\n"
+ "ab-cd\n"
+ "release-1-3-0\n"
+ "a@c\n\n"
+ "a-\n"
+ "-b\n"
+ "-b-\n"
+ "a.b";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}