$re = '/^[a-z0-9]([-a-z0-9]{,61}[a-z0-9])?$/m';
$str = 'a
ab
abc
a-b
ab-cd
release-1-3-0
a@c
a-
-b
-b-
a.b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);