$re = '/PO\h*-\h*\K|(?<!\G)\b([A-Z\d]{5})\b/';
$str = 'License #: U9X5L
Purchase #:PO-A6H4Y
Purchase #:PO - A6H4Y
SKU #: IRK5L8BN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);