re = /PO\h*-\h*\K|(?<!\G)\b([A-Z\d]{5})\b/
str = 'License #: U9X5L
Purchase #:PO-A6H4Y
Purchase #:PO - A6H4Y
SKU #: IRK5L8BN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end