package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\bpassword[\s:]*(\w+)`)
var str = `My email javacoder@gmail.com with password SECRET115. Here is my old PASSWORD: PASS111.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}