$re = '/\bpassword[\s:]*(\w+)/mi';
$str = 'My email javacoder@gmail.com with password SECRET115. Here is my old PASSWORD: PASS111.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);