package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(((-?[1-9]+)+ +)+0)`)
var str = `p cnf 100 430
-3 45 40 0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}