$re = '/(((-?[1-9]+)+ +)+0)/m';
$str = 'p cnf 100 430
-3 45 40 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);