#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*Critical)(?P<hour>\d{2}):(?P<min>\d{2}):(?P<sec>\d{2}):(?P<milsec>\d{3}) (\[Loot] Gained (?P<xp>\S+) XP?|\[Loot] Item Acquired: (?P<loot>.*)|\[Loot] Gained (?P<dram>\S+) Dram?|\[Loot] Earned (?P<reputation>\S+) Reputation?|\[Combat] (?P<dude_hurt>.+) took (?P<damages>\S+) damage from (?P<damage_dealer>[\S]+))"
Local $sString = "19:59:16:394 [Combat] player1 took 4301 damage from Stafrusher(47)" & @CRLF & _
"" & @CRLF & _
"19:59:16:547 [Combat] Stafrage(45) took 12049 damage from player2" & @CRLF & _
"" & @CRLF & _
"19:59:17:060 [Combat] Stafrage(45) took 8621 damage from player3 (Critical)" & @CRLF & _
"" & @CRLF & _
"19:59:17:375 [Combat] Stafrage(45) took 7931 damage from player2 (Critical)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")