import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*Critical)(?P<hour>\\d{2}):(?P<min>\\d{2}):(?P<sec>\\d{2}):(?P<milsec>\\d{3}) (\\[Loot] Gained (?P<xp>\\S+) XP?|\\[Loot] Item Acquired: (?P<loot>.*)|\\[Loot] Gained (?P<dram>\\S+) Dram?|\\[Loot] Earned (?P<reputation>\\S+) Reputation?|\\[Combat] (?P<dude_hurt>.+) took (?P<damages>\\S+) damage from (?P<damage_dealer>[\\S]+))";
final String string = "19:59:16:394 [Combat] player1 took 4301 damage from Stafrusher(47)\n\n"
+ "19:59:16:547 [Combat] Stafrage(45) took 12049 damage from player2\n\n"
+ "19:59:17:060 [Combat] Stafrage(45) took 8621 damage from player3 (Critical)\n\n"
+ "19:59:17:375 [Combat] Stafrage(45) took 7931 damage from player2 (Critical)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}