const regex = /^([A-Za-z_-]+)(?:\[([A-Za-z_-]+)(?:(=|\*=)"([^"]+)")?(?:\s*:\s*(.*))?])+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z_-]+)(?:\\[([A-Za-z_-]+)(?:(=|\\*=)"([^"]+)")?(?:\\s*:\\s*(.*))?])+$', 'gm')
const str = `div[id="fb-share-button"]
div[class*="fb-share-button"]
my-tag[class-name="wup"]
my-tag[my-awesome-attribute-just-exists]
my-tag[my-awesome-attribute-just-exists][and-another-one="wup"]
div[data-settings:matchesUrl()]
div[data-settings:matchesUrl(arg1=test,arg2=test2)]
div[class-name="wup"][data-settings:matchesUrl(arg1=test,arg2=test2)]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}