$re = '/^([A-Za-z_-]+)(?:\[([A-Za-z_-]+)(?:(=|\*=)"([^"]+)")?(?:\s*:\s*(.*))?])+$/m';
$str = 'div[id="fb-share-button"]
div[class*="fb-share-button"]
my-tag[class-name="wup"]
my-tag[my-awesome-attribute-just-exists]
my-tag[my-awesome-attribute-just-exists][and-another-one="wup"]
div[data-settings:matchesUrl()]
div[data-settings:matchesUrl(arg1=test,arg2=test2)]
div[class-name="wup"][data-settings:matchesUrl(arg1=test,arg2=test2)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);