#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#(?![\da-f]{6}|[\da-f]{3}).{0,7}"
Local $sString = "html{ " & @CRLF & _
" color: #e1e1e;" & @CRLF & _
" background-color: #1e1e1e;" & @CRLF & _
"}" & @CRLF & _
"body{" & @CRLF & _
" color: #55432c;" & @CRLF & _
" background-color: #53e; " & @CRLF & _
"}" & @CRLF & _
"div{" & @CRLF & _
" color: #55h32c;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")