package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\.cpl(?:[^.].*|$)`)
var str = `C:\Windows\SysWOW64\control.exe mlcfg32.cpl sounds
C:\Windows\SysWOW64\control.exe mlcfg32.cpl
C:\Windows\SysWOW64\control.exe mlcfg32.cpl sounds .whatever
C:\Windows\SysWOW64\control.exe mlcfg32.cpl. sounds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}