import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\.cpl(?:[^.].*|$)";
final String string = "C:\\Windows\\SysWOW64\\control.exe mlcfg32.cpl sounds\n"
+ "C:\\Windows\\SysWOW64\\control.exe mlcfg32.cpl\n"
+ "C:\\Windows\\SysWOW64\\control.exe mlcfg32.cpl sounds .whatever\n"
+ "C:\\Windows\\SysWOW64\\control.exe mlcfg32.cpl. sounds";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}