import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=START)(?s)(.*?)(?=Closing)";
final String string = "more useless gibberish at the begininng...\n"
+ "separated by new lines...\n\n"
+ "START Fund Class Fund Number Fund Currency\n"
+ "XYZ XYZ XYZ USD\n\n"
+ " bunch of text with lots of newlines in between... Closing 11.11 1,111.11 111,111.11\n\n"
+ "more useless gibberish between the groups...\n"
+ "separated by new lines...\n\n"
+ "START Fund Class Fund Number Fund Currency\n"
+ "XYZ XYZ XYZ USD\n\n"
+ "The word START appears in the middle sometimes multiple times, but it's fine bunch of text with lots of newlines in between... Closing 22.22 2,222.22 222,222.22\n\n"
+ "more useless gibberish at the end...\n"
+ "separated by new lines...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}