import re
regex = re.compile(r"(?<=START)(?s)(.*?)(?=Closing)")
test_str = ("more useless gibberish at the begininng...\n"
"separated by new lines...\n\n"
"START Fund Class Fund Number Fund Currency\n"
"XYZ XYZ XYZ USD\n\n"
" bunch of text with lots of newlines in between... Closing 11.11 1,111.11 111,111.11\n\n"
"more useless gibberish between the groups...\n"
"separated by new lines...\n\n"
"START Fund Class Fund Number Fund Currency\n"
"XYZ XYZ XYZ USD\n\n"
"The word START appears in the middle sometimes multiple times, but it's fine bunch of text with lots of newlines in between... Closing 22.22 2,222.22 222,222.22\n\n"
"more useless gibberish at the end...\n"
"separated by new lines...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")