const regex = new RegExp('\\d{4}-\\d{1,2}-\\d{1,2}_\\d{1,2}\\.\\d{1,2}\\.\\d{1,2}', 'gm')
const str = `file_name_example_2022-11-17_14.45.56.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}