re = /\d{4}-\d{1,2}-\d{1,2}_\d{1,2}\.\d{1,2}\.\d{1,2}/m
str = 'file_name_example_2022-11-17_14.45.56.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end