$re = '/^\d{5,8}(?:_\d{5,8})+_?$/m';
$str = '123456_123456
12345678_12345678_12345678
123456_12345678_123456_12345678
12345_123456_1234567_12345678_
12334_
123456_1
123456_12
123456_1594126781
123_1594126781';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);