#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-z_\s]+):(.*)"
Local $sString = "audit_schema_version:1" & @CRLF & _
"event_time:2020-01-23 02:04:52.8531183" & @CRLF & _
"sequence_number:1" & @CRLF & _
"action_id:LGIF" & @CRLF & _
"succeeded:false" & @CRLF & _
"is_column_permission:false" & @CRLF & _
"session_id:0" & @CRLF & _
"server_principal_id:0" & @CRLF & _
"database_principal_id:0" & @CRLF & _
"target_server_principal_id:0" & @CRLF & _
"target_database_principal_id:0" & @CRLF & _
"object_id:0" & @CRLF & _
"user_defined_event_id:0" & @CRLF & _
"transaction_id:0" & @CRLF & _
"class_type:LX" & @CRLF & _
"duration_milliseconds:0" & @CRLF & _
"response_rows:0" & @CRLF & _
"affected_rows:0" & @CRLF & _
"client_ip:10.122.11.71" & @CRLF & _
"permission_bitmask:00000000000000000000000000000000" & @CRLF & _
"sequence_group_id:259EA444-6A54-41A4-AB05-543F2CA2759D" & @CRLF & _
"session_server_principal_name:" & @CRLF & _
"server_principal_name:iamfake" & @CRLF & _
"server_principal_sid:" & @CRLF & _
"database_principal_name:" & @CRLF & _
"target_server_principal_name:" & @CRLF & _
"target_server_principal_sid:" & @CRLF & _
"target_database_principal_name:" & @CRLF & _
"server_instance_name:2019DB1" & @CRLF & _
"database_name:" & @CRLF & _
"schema_name:" & @CRLF & _
"object_name:" & @CRLF & _
"statement:Login failed for user 'iamfake'. Reason: Could not find a login matching the name provided. [CLIENT: 10.1.11.71]" & @CRLF & _
"additional_information:<action_info xmlns="http://schemas.microsoft.com/sqlserver/2008/sqlaudit_data"><pooled_connection>0</pooled_connection><error>0x00004818</error><state>5</state><address>10.1.11.71</address></action_info>" & @CRLF & _
"user_defined_information:" & @CRLF & _
"application_name:Microsoft® Windows® Operating System" & @CRLF & _
"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")