import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z_\\s]+):(.*)";
final String string = "audit_schema_version:1\n"
+ "event_time:2020-01-23 02:04:52.8531183\n"
+ "sequence_number:1\n"
+ "action_id:LGIF\n"
+ "succeeded:false\n"
+ "is_column_permission:false\n"
+ "session_id:0\n"
+ "server_principal_id:0\n"
+ "database_principal_id:0\n"
+ "target_server_principal_id:0\n"
+ "target_database_principal_id:0\n"
+ "object_id:0\n"
+ "user_defined_event_id:0\n"
+ "transaction_id:0\n"
+ "class_type:LX\n"
+ "duration_milliseconds:0\n"
+ "response_rows:0\n"
+ "affected_rows:0\n"
+ "client_ip:10.122.11.71\n"
+ "permission_bitmask:00000000000000000000000000000000\n"
+ "sequence_group_id:259EA444-6A54-41A4-AB05-543F2CA2759D\n"
+ "session_server_principal_name:\n"
+ "server_principal_name:iamfake\n"
+ "server_principal_sid:\n"
+ "database_principal_name:\n"
+ "target_server_principal_name:\n"
+ "target_server_principal_sid:\n"
+ "target_database_principal_name:\n"
+ "server_instance_name:2019DB1\n"
+ "database_name:\n"
+ "schema_name:\n"
+ "object_name:\n"
+ "statement:Login failed for user 'iamfake'. Reason: Could not find a login matching the name provided. [CLIENT: 10.1.11.71]\n"
+ "additional_information:<action_info xmlns=\"http://schemas.microsoft.com/sqlserver/2008/sqlaudit_data\"><pooled_connection>0</pooled_connection><error>0x00004818</error><state>5</state><address>10.1.11.71</address></action_info>\n"
+ "user_defined_information:\n"
+ "application_name:Microsoft® Windows® Operating System\n"
+ ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}