$re = '/\b(?:hello|meeting)\b|([^\W\d_])\1+/m';
$str = 'hello, join this meeting heere using thiis lllink';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);