re = /\b(?:hello|meeting)\b|([^\W\d_])\1+/m
str = 'hello, join this meeting heere using thiis lllink'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end