re = /((https?:\/\/)|(\/)|(..\/))(\w+:{0,1}\w*@)?(\S+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?/m
str = 'https://www.test.com
https://test.com
http://www.test.com
http://test.com
https://test.com/123
https://test.com/123/456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end