import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^r\\d+---sn-vgqs[a-z0-9]{4}\\.googlevideo\\.com$";
final String string = "r4---sn-vgqsrnez.googlevideo.com\n"
+ "r1---sn-vgqsknlz.googlevideo.com\n"
+ "r5---sn-vgqskn7e.googlevideo.com\n"
+ "r3---sn-vgqsknez.googlevideo.com\n"
+ "r6---sn-vgqs7ney.googlevideo.com\n"
+ "r4---sn-vgqskne6.googlevideo.com\n"
+ "r4---sn-vgqsrnez.googlevideo.com\n"
+ "r5---sn-vgqskn76.googlevideo.com\n"
+ "r6---sn-vgqs7ns7.googlevideo.com\n"
+ "r1---sn-vgqsener.googlevideo.com\n"
+ "r1---sn-vgqskn7z.googlevideo.com\n"
+ "r1---sn-vgqsknek.googlevideo.com\n"
+ "r6---sn-vgqsener.googlevideo.com\n"
+ "r3---sn-vgqs7nly.googlevideo.com\n"
+ "r1---sn-vgqsknes.googlevideo.com\n"
+ "r4---sn-vgqsrnes.googlevideo.com\n"
+ "r6---sn-vgqskn76.googlevideo.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}