using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[GROUP2]([\s\S]+)(?=\n\n|\z)";
string input = @"[GROUP1]
;This is something I don't want
COMMAND(value:test)
COMMAND(value:[type=""submit""])
COMMAND(value:test)
COMMAND(value:test)
[GROUP2]
;This is something I don't want
COMMAND(value:test)
COMMAND(value:[type=""submit""])
COMMAND(value:test)
COMMAND(value:test)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}