$re = '/^\[GROUP2]([\s\S]+)(?=\n\n|\z)/m';
$str = '[GROUP1]
;This is something I don\'t want
COMMAND(value:test)
COMMAND(value:[type="submit"])
COMMAND(value:test)
COMMAND(value:test)
[GROUP2]
;This is something I don\'t want
COMMAND(value:test)
COMMAND(value:[type="submit"])
COMMAND(value:test)
COMMAND(value:test)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);