import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.Items\\(.*?\\)(\\W.*(?!\\.Select\\(.+\\)))?(\\W.*)?\\;";
final String string = "Cars.Items()\n"
+ " .Where(x => x.Year == \"1988\")\n"
+ " .Select(x => new { x.Registration })\n"
+ " .ToList();\n\n"
+ "Cars.Items()\n"
+ " .Where(x => x.Id == 1923984)\n"
+ " .Select(x => new { x.Registration })\n"
+ " .FirstOrDefault;\n\n"
+ "Cars.Items()\n"
+ " .Where(x => x.Id == 1923984)\n"
+ " .FirstOrDefault;\n\n"
+ "Cars.Items();\n\n"
+ "Cars.Items()\n"
+ ".GroupBy(g => g.Key).First();";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}